1. #1
    Senior Member Follow User Gallery
    Join Date
    Apr 2005
    Location
    Pittsboro, NC
    Age
    38
    Posts
    609

    Default NanoTile Textures! unofficial - Information, Installation

    NanoTile Textures! unofficial - Information, Installation

    NanoTile Textures!
    [CLICK HERE TO GET CURRENT VERSION]
    (Current Version is 2.3 Updated 10/28/2015)
    by: Joseph Drust

    NanoTile Textures is a plugin that allows for the creation of tiling textures using NanoMeshes inside of ZBrush.

    This plugin is unofficial.




    Main features


    • Allows the creation of seamless tiling textures using NanoMesh indexes
    • Respects polypainted and textured NanoMeshes
    • Can create ZBrush rendered: BPR, Preview, Albedo, AO, Normal, Bump, Polygroup ID, and Height Maps
    • Will generate 256, 512, 1024, 2048, and 4096 resolution textures


    Usage






    Installation

    **** Make sure you have updated to 'ZBrush 4R7 P2' or later! *****

    ZBrush 4R7 32bit:
    UnZip the attached NanoTileTextures_v1.2_x32.ZIP file to your \Pixologic\ZBrush 4R7\ZStartup\ZPlugs\ folder.
    Restart ZBrush.
    NanoTile Textures will be located under the Zplugin tab.

    ZBrush 4R7 64bit:
    UnZip the attached NanoTileTextures_v1.2_x64.ZIP file to your \Pixologic\ZBrush 4R7\ZStartup\ZPlugs64\ folder.
    Restart ZBrush.
    NanoTile Textures will be located under the Zplugin tab.

    **** Make sure you have updated to 'ZBrush 4R7 P2' or later! *****

    *It is recommended that you turn on the 'Load Example Tile Tool' before clicking 'Create New TileTool' on your first usage of the tool.
    *When using any of the 'Var' or 'Random Distribution' options in NanoMesh be sure toTurn OFF 'RandArray' [Tool:NanoMesh:RandArray] or the outputted textures will not tile correctly.
    *As always, remember to save before using!

    Change Log

    v1.2: Initial Public Release

    Notes

    I have been greatly enjoying the NanoMesh functionality since the release of 4R7 and decided to create and share this plugin to generate tiling NanoMesh Texture Maps.

    This Plugin has not been mass tested and my scripting knowledge is not all that great; there are bound to be bugs. Please post any bugs you come across (along with information on OS and version of 4R7 (x32/x64) that you are using) and I will try and fix them :)

    Special thanks to Marcus_Civis for the endless coding assistance and Nick Reynolds for testing!

    Hope the plugin helps; feel free to share any images of created textures in this thread.

    -Joseph

    P.S. I am in the process of updating all my other released plugin mess to work with 4R7 x32 and x64 :)

    [CLICK HERE TO GET CURRENT VERSION]
    Attached Files Attached Files

  2. #2
    Senior Member Follow User Gallery
    Join Date
    Apr 2005
    Location
    Pittsboro, NC
    Age
    38
    Posts
    609

    Default

    Here are two example test images created with the plugin.
    (AO pass has been updated since these images were created.)





    -Joseph

  3. #3
    Senior Member Follow User Gallery
    Join Date
    Aug 2011
    Location
    Mebane, NC
    Posts
    4,164

    Default

    Wow. Very nice. Thank you. I just downloaded ZWelder 1.7; hoping it will work in 4R7(x64)

  4. #4

  5. #5
    Senior Member Follow User Gallery
    Join Date
    Feb 2007
    Location
    Wellington, NZ
    Posts
    185

    Default

    Great stuff Joseph. Will there be a 8k option added ?

    Also one little note, you are creating a total of 8 instances of the plane. You really only need 3+original which should speed up performance

    (really hoping P3 fixes the highpoly nanomesh bug)
    Jens Kafitz
    Sr. Texture Artist & Environment Artist


  6. #6
    Member Follow User Gallery
    Join Date
    Sep 2010
    Location
    Ft Lauderdale, FL
    Age
    53
    Posts
    31

    Default

    Impressive stuff Joseph! Thank you!

  7. #7

    Default

    Awesome stuff!
    Thanks heap for this sharing!


  8. #8
    Senior Member Follow User Gallery
    Join Date
    Aug 2011
    Location
    Mebane, NC
    Posts
    4,164

    Default

    Win 7 ZBrush 4R7 P2(x64)
    On testing, I exported all file passes. Color and AO filled the frame. Other images had a border on the top and bottom as well as the left side.
    I was able to get ZWelder functional with (x64) by placing the .zsc in the zplugs64 folder and the data folder under ZPlugs , haven't tested extensively though.

  9. #9
    Senior Member Follow User Gallery
    Join Date
    Oct 2005
    Location
    USA
    Age
    33
    Posts
    1,033

    Default

    I followed the install steps but the 64 bit version of this plugin makes it so zbrush won't even start up.

    The 32bit version of this plugin works fine for me however.

    Removing the 64 bit plugin from my "C:\Program Files (x86)\Pixologic\ZBrush 4R7\ZStartup\ZPlugs64\" lets zbrush run again.

  10. #10
    Senior Member Follow User Gallery
    Join Date
    Feb 2007
    Location
    Wellington, NZ
    Posts
    185

    Default

    On testing, I exported all file passes. Color and AO filled the frame. Other images had a border on the top and bottom as well as the left side.
    Make sure to turn off 'RandArray' in Nanomesh. Otherwise it will never tile.
    Jens Kafitz
    Sr. Texture Artist & Environment Artist


  11. #11
    New Member Follow User Gallery
    Join Date
    Mar 2006
    Location
    Huntington Beach, CA
    Posts
    6

    Default

    This script also a bonus function and makes it really easy to place IMM brushes and have them tile.

    Thanks for making this!

    -Nick
    Nick Reynolds
    Lead Environment Artist: Sony Santa Monica

  12. #12
    Senior Member Follow User Gallery
    Join Date
    Apr 2005
    Location
    Pittsboro, NC
    Age
    38
    Posts
    609

    Default

    @campi: Ohh those 8k textures; I'll see what I can do Thanks for the video link; the 4 plane offset is a great idea! I will look into a possible 'performance' toggle mode. Currently I have been just turning off the Array temporarily and working on the middle plane then turning it back to preview/generate the maps.

    @--E--: Are you running 4R7 P2? It may crash since if you are attempting to run on a version of 4R7 that isn't upgraded to 'P2'. That or possibly the *x64.zip was corrupted on download (since you mention it is working with the x32 version.)

    @Doug Jones: The current released ZWelder version may only work in x32 4R7 atm. I haven't got around to looking at that one yet.
    In 4R7 the 'WeldDist' [Tool:Geometry:Modifiy Topology:WeldDist] slider has been increased when with 'WeldPoints' [Tool:Geometry:Modify Topology:WeldPoints] this may generate a better weld now then the ZWelder will even with it updated for 4R7.

    For the file passes as campi mentioned; turning off 'RandArray' and being upgraded to 4R7 P2 should generate seamless passes.

  13. #13
    Senior Member Follow User Gallery
    Join Date
    Aug 2011
    Location
    Mebane, NC
    Posts
    4,164

    Default

    "RandArray" is probably the culprit. Figured it would work as other exporters, renders images, then exports maps. I changed nothing and got 2 tiles right and several wrong. Maybe changing something in the code could avert that?

  14. #14

    Default

    i love updates. Keep up the good fight Drust!

  15. #15

    Default

    Is it me or both 32 or 64 bits version have exact same file sizes/CRC ?
    Edit: ok it was me -_- DLLs are the same but not the ZSC files. (and I can't even delete that, horray)

Page 1 of 8 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •