1. #1
    Senior Member Follow User Gallery
    Join Date
    Sep 2010
    Posts
    786

    Default Disable Right Click Menu

    I like to use Right Click navigation. However sometimes it will popup the quick menu. This menu is also hotkeyed to the space bar. I prefer to keep Right Click navigation and just use the space bar for the quick menu.

    Is there a way to disable the quick menu popup from right click?

  2. #2
    Moderator Follow User Gallery
    Join Date
    Jun 2004
    Location
    UK
    Posts
    8,748

    Default

    I don't think it's possible.

  3. #3
    New Member Follow User Gallery
    Join Date
    Mar 2012
    Location
    Austin, TX
    Posts
    7

    Default

    I also use right click navigation, and the QuickMenu popping up is a constant annoyance. I would love to have the ability to disable the shortcut. Anyone know how??

  4. #4
    Senior Member Follow User Gallery
    Join Date
    Dec 2008
    Posts
    215

    Lightbulb

    Try this (Preferences -> Interface ->click time 0.01 from user informerman
    on cgsociety forums.
    Disable rightclick menu?

  5. #5

    Thumbs down

    Unfortunately that doesn't help.

    The right click menu is SO ANNOYING. The heavier the scene gets, the worse it is.

    If your a right click navigator like myself, it pops up randomly while navigating, then throws your focal shift to a bad number, or your intensity.

    ZBRUSH ppl please fix this! It's a major oversite in the preferences, should have a TURN OFF option.

    The rclick navigation menu is just plain irritating.

  6. #6
    Senior Member Follow User Gallery
    Join Date
    Sep 2010
    Posts
    786

    Default

    Quote Originally Posted by jawa64 View Post
    Try this (Preferences -> Interface ->click time 0.01 from user informerman
    on cgsociety forums.
    Disable rightclick menu?
    So far this seems to work fine for me.

  7. #7
    New Member Follow User Gallery
    Join Date
    Mar 2012
    Location
    Austin, TX
    Posts
    7

    Default

    I agree that changing the click time to .01 does help prevent the QuickMenu from popping up. But this fix unfortunately affects all clicks and brusk strokes. For example, changing to .01 makes toggling visibility and isolating polygroups practically impossible for me. I've also noticed brushes acting strangely as well.

    The click time solution causes more problems than it solves, and is really a band aid to what should be a simple "on/off" option.

  8. #8
    Senior Member Follow User Gallery
    Join Date
    Sep 2010
    Posts
    786

    Default



    Yeah I had to change the click time back to its default setting. Messes up masking, selections and other things. Really they need a toggle for it. It seems like bad design idea when you create a popup menu that can't be turned off and then turn around and setup a navigation feature that uses the same input device button.

  9. #9

    Default



    Agreed, I tried the click .01 it does not help. If your trying it with a box in the scene maybe, but most people have a hi poly character with multiple groups of outfit components.

    It gets to the point, where every time you 'right click navigate' that 'right click menu' get's in the way constantly. Your thrown into the slider for focal shift when you just want to rotate your viewport.

    This has been complained about for 4 release patches now, and it needs to be FIXED. Make this a removable feature, it is an annoying, feature that completely irritates the user while they are trying to navigate a heavier scene.

    The right click menu btw is useless, I don't need those features so in my face while I work. I use S to resize my brush that's about it... take the r - click navigation menu and put it in the trash where it belongs please and thankyou.

  10. #10
    Senior Member Follow User Gallery
    Join Date
    May 2008
    Location
    Simi Valley/San Jose, CA.
    Age
    28
    Posts
    284

    Default

    Has anyone figured out a solution for this? I also am getting tired of this menu.

  11. #11
    Senior Member Follow User Gallery
    Join Date
    Mar 2011
    Location
    chicago
    Age
    25
    Posts
    270

    Default

    ive been waiting for a solution to this for a long time now

  12. #12
    Senior Member Follow User Gallery
    Join Date
    Sep 2010
    Posts
    786

    Default

    Happy to say this is finally fixed in Version 4R4! There's now a toggle button to turn off the right click menu popup. They also fixed right click navigation while in transpose modes.

    Great to know that Pixologic listens to their customers.

  13. #13
    Senior Member Follow User Gallery
    Join Date
    May 2008
    Location
    Simi Valley/San Jose, CA.
    Age
    28
    Posts
    284

    Default

    Pixo... your amazing. I love you! There i said it! Now please please can you teach Autodesk how to create and update a program the right way??

  14. #14
    Senior Member Follow User Gallery
    Join Date
    Jun 2007
    Location
    Eriador
    Posts
    233

    Default

    So glad I finally decided to search for this problem, and finding this thread. This problem has been bugging me ever since they added the otherwise exquisite Rightclick Navigation controls. Thank you Pixologic!

    I hope this also solves the anomaly where ZBrush decides to suddenly 'drop to canvas' a copy of the current tool, forcing you to clear the canvas and redraw the tool.

  15. #15
    Senior Member Follow User Gallery
    Join Date
    Apr 2012
    Location
    Florida
    Posts
    133

    Default Wow

    Thanks so much for this! I have been dealing with this for so long. Incredible!
    _____________________________________
    You know you've been doing too much sculpting when you are washing the car,
    you try to save time by turning on symmetry. www.hardlinedigital.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •